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Accessibility Checklist for Faculty and Course Developers
[bookmark: _GoBack]*** To collapse all headings in this document, right click in one of them and select Expand/Collapse > Collapse All Headings. For instructions on how to implement a specific guideline, click the arrow to the left of the headings below to expand the text, or click them to collapse the explanation. You make the arrows appear by hovering to the left of the headings below. This checklist can also viewed in an expandable/collapsible format on the Adobe Media Server with Chrome browser.
Guidelines that Apply to Word Documents, Blackboard Learn Pages, and Web Pages
Set your document language
1. Set your document language in the application you are working with, or within the head of the HTML page, e.g. <html lang=”en-us”>. In Word, go to File > Options > Language > and select the main language under Choose Editing Languages. If small portions of text are in another language, select that text and go under the Review tab > Language > Set Proofing Language > select the language and click OK.
See: Instructions for Setting Word Document Language
Make sure your text colors have enough contrast with your background
2. Make sure your text colors have enough contrast with your background color to meet the Web Accessibility Initiative’s Web Content Accessibility Guidelines at the AA level. This would be a contrast ratio of 4.5:1 for normal font size (12pt or 16px). The ratio for larger or bold fonts is 3.1:1. The later would include 14 pt bold text, or a large font size such as 18pt or 24px. You don’t have to use black text on a white background for everything. You just need to make sure your text has enough contrast with the background. You can download Colour Contrast Analyser (See: https://developer.paciellogroup.com/resources/contrastanalyser/) to get an application with an eye dropper to sample your font and background colors to check the contrast ratio. 
See page with other color contrast analyzers listed
Don’t use color alone to convey meaning
3. Don’t use color alone to convey meaning, e.g. Don’t present something like, “there will be tests on the dates listed in red,” and then list dates in red and black. Instead, use an asterisk to denote importance, and/or write “Important” beside the important thing. Or simply create a separate list of dates for tests only. If you have a line graph chart, make sure the colors are distinguishable by someone who is color blind. Color Contrast Analyzer by Paciello Group can simulate different color blindness. If you can make different patterned lines, this will also help.
See examples of using color alone and how to avoid it, as well as extensions and tools to help.
Use Word Styles
4. Use Word Styles to create headings in Word documents. 
See: Instructions on how to format with Word Styles.
Ensure heading levels 1-6 are applied in the proper hierarchical manner
5. Ensure heading levels 1-6 are applied in the proper hierarchical manner. Heading Level 1 would be the title of a document, for example. Subheadings would be Heading Level 2, followed by Heading Level 3, etc. See: Instructions on how to format with Word Styles.
Select font faces, font-sizes and colors that show well on screen
6. Select font faces, font-sizes and colors that show well on screen if authoring for online. Sans-serif should be used for body text, such as Arial, Helvetica, Verdana, Tahoma, Trebuchet MS, Myriad Web Pro, or Roboto. Serifs would include Georgia, Times New Roman, or Times. Use relative font sizes, such as ems or percentages. Avoid copying text set in point (pt) or pixel (px) sizes into Blackboard Learn. Don’t use pt or px sizes on text in HTML pages. They won’t scale when a user changes her/his font size in the browser settings. See Formatting for Legibility. See also: Formatting font for readability and accessibility in Blackboard Learn, and the movie tutorial called Formatting text Copied from Word into Blackboard’s Content Editor.
Avoid using Word’s B or I buttons
7. Avoid using Word’s B or I buttons, within the Home ribbon, to create Bold or Italic text. Use Word’s Strong Style in the Styles pane for Bold text, and Word’s Emphasis Style for Italicized text. You can modify these Styles to suit your needs.
See example of B and I buttons to avoid.
Use white space to create separation between groups of related information
8. Use white space to create separation between groups of related information. Adjust white space by modifying a Word Style rather than using the return or enter key. Right click on a Word Style and select Modify. Click the Format button > Paragraph, and adjust space before and after. Line spacing within paragraphs should be 1.5x the text size. Spacing between paragraphs should be 1.5x larger than the line spacing within paragraphs.
See: Instructions on how to format with Word Styles.
Keep line lengths or columns of text to around 80 characters per line
9. Keep line lengths or columns of text to around 80 characters per line.
Present text in a way that it will reflow and remain visible up to a magnification of 200x without horizontal scrolling
10. Present text in a way that it will reflow and remain visible up to a magnification of 200x without horizontal scrolling. See: Building a fluid container for content in Blackboard. And Creating a fluid text wrap around an image.
Use Word Multi-column text tool to create columns of text instead of tabbing or spacing
11. Use Word’s Multi-column text tool to create columns of text instead of tabbing or spacing. Select the text to be formatted in columns > click the Layout tab > Columns > select your number of columns.
Avoid moving text and don’t use images of text
12. Avoid moving text and don’t use images of text. If you have to use a Logotype with text, put the exact text inside the description/alt element.
Create descriptive links
13. Create descriptive links, for example, use “Copyright Advisory Network’s website” as link text instead of “http://librarycopyright.net” or “click here to find out more.” Link text should describe where the link leads.
See: Instructions for Creating Descriptive Links and Tool Tips in Word, and Instructions for creating descriptive links in Blackboard Learn’s Original Experience.
Add alternative text for images that convey information or the null alt element for decorative and redundant images
14. Add alternative text for images that convey information or the null alt element for decorative and redundant images. In Microsoft Office documents, you add alternative text by providing a Description for an image, by right clicking and selecting Format Picture and then selecting the Layout & Properties icon. 
See: Instructions for creating alternative text Descriptions in Word, and look at 
Guidelines for Alternative Text (Blackboard Learn and web pages) as well as the sections that follow it for the different situations in applying alt text, including the null alt attribute to make screen readers ignore a decorative image. If a shape visual is decorative, see Make visuals such as Shapes decorative in Office 365.
Create lists in Word with Word’s list tool
15. Create lists in Word with Word’s list tool, rather than manually numbering items in the list.
Avoid the use of objects that float on the drawing layer of a Word document
16. Avoid the use of objects that float on the drawing layer of a Word document, such as Text Boxes, Shapes, Smart Art, Charts or Word Art. If you use Shapes or Smart Art to create diagrams, use a screen capture application, such as Window’s Snipping Tool to create an image out of the combination. Insert the image with an alternative text Description.  For Text Boxes, create a custom Word Style instead, to create the same effect of a call out box. If you insert a Chart, provide a text description of what the data is conveying. Right click on the chart, and select Format Chart Area, then select the Layout & Properties icon to find the Description field.
See: Instructions for capturing floating objects and writing alternative text for them.
See: Instructions for creating an alternative custom callout style in Word to avoid using a floating text box.
Create simple tables in Word
17. Create simple tables in Word. Avoid combining tables in one, merged or split cells.
Create table headers
18. Create table headers. In Word, simplify your tables to create a single table header row at the top. Highlight the row, right click and select Table Properties. Under the Row tab, check the box next to “Repeat as a header row across the top of each page.”  In HTML, you can use the <th> element and the scope attribute to designate single row or single column headers. If you have multiple headers, use the "ID" attribute on your <th> table heading cells, and the “headers” attribute on your <td> table data cells to identify which headers a screen reader should read before the data in the cell. 
See: Instructions for creating a header row in a Word table and hear example of JAWS reading merged tables. For single levels of row and and column headers, see Instructions for setting up heading elements and scope attributes for row and column headers. For multilevel heading cells, see: Instructions on how to set up code for proper reading of header cells before data cells
Provide Alt Text to Tables that are more complex
19. Provide Alt Text to Tables that are more complex. If you have a table that isn’t as simple as having one header row at the top, you can give an alternative text description of the data contained in the table. Select the table. Right click on the table and select Table Properties from the context menu. In the Table Properties pane, select Alt Text. Add your alternative text description in the Description field.
Use Word’s built in accessibility checker
20. Use Word’s built in accessibility checker to help find areas that need accessibility features added. 
See: Instructions for using Word’s built-in accessibility checker.
Power Point
Start with accessible PowerPoint templates
1. When searching for Power Point 2016 or 365 templates, type "accessible" as a search term to bring up accessible templates.
Stick to PowerPoint slide layouts and placeholders
2. Create slides from the Layout menu options and use their placeholders to add your content.
Write unique slide titles
3. Create unique slide titles. This will create a table of contents for screen reader users.
Use the Selection Pane to order elements on your slide in logical reader order
4. Use z-order on slides. A screen reader reads objects from back to front, or from bottom to top in the selection pane. On the Home tab, click on Select, and then Selection Pane. Drag the order of the elements in the list to read in the logical order. 
Work in the theme or Master slides for changes
5. Don’t customize colors inside individual slides, but do this inside the theme or in the Master slides instead. Students with low vision need to adjust document colors sometimes to help them read. If you stick with standardizing the theme slides, they can affect the color or contrast change across the set of slides more easily.
Provide alternative text for non-text elements
6. Provide alternative text for non-text elements in the same manner you would do for Word documents. See: Adding alt text to visuals in Office 365. If a visual is decorative, see Make visuals such as Shapes decorative in Office 365.
Create contrast between text and background colors to meet WCAG 2.0 AA
7. Create enough contrast between the text color and background to meet WCAG 2.0 AA standards in the same manner you would do for Word documents. 
Use easy to read fonts
8. Use fonts for readability and legibility in the same manner as you would for Word documents.
Write descriptive hyperlink text
9. Create descriptive hyperlink text in the same manner as you would for a Word document.
Create simple tables
10. Use simple table structure. Create one row of headers at the top of the table. Click in the top row of the table. Under the Design tab, select the check box to the left of Header Row to add a visual header row at the top of the table. To make visual headers out of the first column of the table, select First Column. Don't use merged or split cells.
Provide transcriptions of audio and video
11. Transcribe any audio or video in the slides. You can use a word processor or text editor like Notepad for this.
Provide captions for audio and video files
12. Use audio or video files with captions. See: Add captions or subtitles in PowerPoint. Note: you can generate and download a .vtt caption file to add to PowerPoint video, if you upload your video to Youtube, correct the captioning in Youtube, and then download the .vtt file.
Use the built in accessibility checker
13. Use Power Points built in Accessibility Checker. It's under File > Info > Check for Issues > Check Accessibility.

Articles and Scanned Documents in Courses (PDF)
Don’t scan images of articles/text or other learning materials on a copier and then put the PDF in the course
1. Don’t scan images of articles/text or other learning materials on a copier and then put the PDF in the course. Many of these become inaccessible images of text. Find the link to the HTML version of a journal article online, through our library’s website, and put this link within your course. Be cautious about putting PDFs from publishers online because they often are not completely accessible. They may contain “searchable text,” but often the read order is incorrect, and these documents are untagged. Without the tagging, a screen reader user who is blind, won’t have the semantic elements they use to navigate quickly, like headings, descriptive links, proper list markup, etc. See: How to tell the difference between an accessible PDF and a scanned image of text.
Take printed hard copies of learning materials to Electronic Course Reserves on the 8th floor of the Michael Schwartz Library.
2. Take printed hard copies of learning materials to Electronic Course Reserves on the 8th floor of the Michael Schwartz Library and have it scanned on the Bookeye scanner if you can’t find an online version of a learning material that you need put within a course,. This will produce an image that will convert via optical character recognition (OCR) much nicer than a book laid on a copier. See: The BookEye Scanner in Electronic Course Reserves at CSU. 
Video and Multimedia
Find and use video that is already captioned
1. Find and use video that is already captioned. Accuracy and synchronization are important! If you have access to the video file, you can upload it to Youtube and fix the captions after Youtube has time to automatically caption it. See: Edit or remove captions in Youtube and Use Automatic Captioning in Youtube. You can then download the Youtube caption file in .srt format and upload this to Tegrity. Another type of Youtube caption file format, .vtt, may be used in other applications that will accept it. See: How to add closed captioning (CC) to a recording in Tegrity. 
Provide audio descriptions
2. Provide audio descriptions of what is occurring if important non-verbal information exists in the audio or video recording.
Add captions to Youtube videos owned by others
3. Add captions to Youtube videos owned by others. If you find an uncaptioned video on Youtube that you’d like to use in your course, create a free Amara.org account and caption the video through Amara’s free platform and Amara Public Editor.
Write a transcript of audio or video used in your course
4. Write a transcript of audio or video used in your course for people who are blind-deaf or have low bandwidth. See: Best Free Way to Automatically Transcribe Video (Audio to Text). You can also download an edit a caption file from Youtube, once you've added accurate captioning there to create a transcript.
Check Accessibility of Websites
Use a web accessibility checker to check web pages
1. Use a free web accessibility checker to check web pages. Wave extension for Chrome is one. Deque's aXe extension is another. Wave extension for Chrome will check the accessibility of internal pages, and those with JavaScript. Once installed in Chrome browser, you activate it by clicking the icon at the top that looks like a circle with a "W" inside of it. [image: ] A pane will open on the left side of the browser with information about the good and the bad that it found. Visual markers will be put within the web page to designate various features relating to accessibility, e.g. missing headings, or alt text. For those who haven't worked with HTML, it's an easy interface to understand.  See an explanation of WAVE Web Accessibility Evaluation Tool.

aXe Developer Tools exist within an extension for Chrome or Add-on for Firefox. aXe will also highlight problem areas in the web page, explain what the error is that is found, and show the code involved. Once installed, it is accessed through the developer tools under the aXe tab. You simply navigate to the page you would like to check and click the Analyze button within the aXe tab. See an explanation on how to use aXe Accessibility Audit Tool.
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